?

Log in

No account? Create an account
LogJam [entries|archive|friends|userinfo]
LogJam

[ website | LogJam ]
[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

failure to install on SuSE 9.0 [Jan. 10th, 2004|03:22 pm]
LogJam

logjam

[terpsichoros]
Using the RPM, upgrading from 3.0.4 (installed by compiling from source and using checkinstall):
linux:/usr/src # rpm -Uvh packages/logjam-4.2.3-1.i386.rpm
error: Failed dependencies:
libcom_err.so.3 is needed by logjam-4.2.3-1
libcrypto.so.4 is needed by logjam-4.2.3-1
libgssapi_krb5.so.2 is needed by logjam-4.2.3-1
libk5crypto.so.3 is needed by logjam-4.2.3-1
libkrb5.so.3 is needed by logjam-4.2.3-1
libpspell.so.4 is needed by logjam-4.2.3-1
libssl.so.4 is needed by logjam-4.2.3-1


Compiling:
linux:/usr/src/logjam-4.2.4 # ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for mingw... no
checking for pkg-config... /usr/local/bin/pkg-config
checking for gtkspell-2.0... yes
checking for libgtkhtml-3.0... not found
checking for librsvg-2.0 > 2.2.3... not found
checking for gtk+-2.0 gmodule-2.0 libxml-2.0 gtkspell-2.0... Package libxml-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxml-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxml-2.0' found

configure: error: Library requirements (gtk+-2.0 gmodule-2.0 libxml-2.0 gtkspell-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
LinkReply

Comments:
[User Picture]From: terpsichoros
2004-01-12 05:55 am (UTC)

Re: Missing/Wrong Versions

I have libcom_err.so.2 - the rpm asks for libcom_err.so.3
I have libcrypto.so.0.9.7 - the rpm asks for libcrypto.so.4
I have libgssapi.so.1- the rpm asks for libgssapi_krb5.so.2
I don't have libk5crypto.so.3, at least not anything with a similar name.
I have libkrb5.so.17 - the rpm asks for libkrb5.so.3
I have libpspell.so.15 - the rpm asks for libpspell.so.4
I have libssl.so.0.9.7 - the rpm asks for libssl.so.4

SuSE spells libxml-2 as libxml2, which might cause errors with ./configure even though I have the devel packages installed.
(Reply) (Parent) (Thread)
[User Picture]From: synestine
2004-01-12 05:26 pm (UTC)

Re: Missing/Wrong Versions

On my system, libcom_err.so.3 is owned by krb5-libs-1.3.1-6, libcrypto.so.4 is a symlink to libcrypto.so.0.9.7a, libgssapi_krb5.so.2 is also owned by krb5-libs-1.3.1-6, and it seems like the majority of them are compile-time options in the security libs. As for the libxml-2 vs libxml2, that's possible. If the .pc (IIRC) file isn't named the right way, pkgconfig can't find it, however, if you symlink it, it may just get past that.
(Reply) (Parent) (Thread)