?

Log in

No account? Create an account
ok, can anyone explane this one to me? - LogJam [entries|archive|friends|userinfo]
LogJam

[ website | LogJam ]
[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

ok, can anyone explane this one to me? [May. 2nd, 2003|07:30 pm]
LogJam

logjam

[mrfallejr]
[Current Mood |confusedconfused]

/home/geek/downloads
joo 4r3 r00t3d ->rpm -Uvh logjam-4.1.2-1.i386.rpm
error: Failed dependencies:
libgal-2.0.so.2 is needed by logjam-4.1.2-1
libgtkhtml-3.0.so.1 is needed by logjam-4.1.2-1
libgtkhtml-a11y-3.0.so.1 is needed by logjam-4.1.2-1
/home/geek/downloads
joo 4r3 r00t3d ->rpm -Uvh libgal2-1.99.3-1.i386.rpm
error: Failed dependencies:
libgnomecanvas >= 2.2.0.2-1 is needed by libgal2-1.99.3-1
/home/geek/downloads
joo 4r3 r00t3d ->rpm -Uvh libgnomecanvas-2.2.0.1-1.i386.rpm
Preparing... ########################################### [100%]
package libgnomecanvas-2.2.0.1-1 is already installed
/home/geek/downloads
joo 4r3 r00t3d ->

mind you that the libgtkhtml on my system is also the latest version
LinkReply

Comments:
[User Picture]From: mrfallejr
2003-05-02 04:37 pm (UTC)

oops... forgot part of the equation...

/home/geek/downloads/logjam
joo 4r3 r00t3d ->rpm -Uvh gtkhtml3-3.0.2-2.i386.rpm
error: Failed dependencies:
libgal-2.0.so.2 is needed by gtkhtml3-3.0.2-2
/home/geek/downloads/logjam
joo 4r3 r00t3d ->
(Reply) (Thread)
From: evan
2003-05-02 04:42 pm (UTC)
I don't use Redhat, but:
libgnomecanvas >= 2.2.0.2-1 is needed by libgal2-1.99.3-1
                  ^^^^^^^^^
joo 4r3 r00t3d ->rpm -Uvh libgnomecanvas-2.2.0.1-1.i386.rpm
                                         ^^^^^^^^^

Those versions don't quite match. Could that be the problem there?
(Reply) (Thread)
From: compwiz
2003-05-02 05:34 pm (UTC)
It's a great argument against 5-part version numbers (barf).
(Reply) (Parent) (Thread)
[User Picture]From: spot
2003-05-02 06:25 pm (UTC)
Yeah, but RPM is doing the right thing here.
(Reply) (Parent) (Thread)
From: compwiz
2003-05-02 06:41 pm (UTC)

Re:

Doesn't prevent against human confusion :)
(Reply) (Parent) (Thread)
[User Picture]From: mrfallejr
2003-05-02 06:47 pm (UTC)

Re:

*smacks forhead* yeah, that could be

silly me thought that freshrpms and rpmfind would be up to date
(Reply) (Parent) (Thread)
[User Picture]From: spot
2003-05-02 06:27 pm (UTC)
Well, this isn't Red Hat Linux 9, or you wouldn't be getting these errors. I strongly suggest that you download the src.rpm and run: rpmbuild --rebuild logjam-4.1.2-1.src.rpm

Then, install the binary rpm that it generates.
(Reply) (Thread)
[User Picture]From: mrfallejr
2003-05-02 06:54 pm (UTC)

Re:

you sure, up2date tells me that i've upgraded to RH 9
i've been trying to double check the version numbers (all 4+ digits) against the sources i use, and i'm finding that rpmfind dosn't offer the latest and geatest like i thought :(

i'll try the .src.rpm

thanks :)
(Reply) (Parent) (Thread)
[User Picture]From: quelrod
2003-05-02 08:44 pm (UTC)
real men compile from source... ;)
actually rpms always frustrated me so i use slackware.
(Reply) (Thread)
[User Picture]From: mrfallejr
2003-05-03 01:19 am (UTC)

Re:

oh, i'll be using a source disto... soon!
i just have to get our of college first
FT work + PT classes != a happy linux user
(Reply) (Parent) (Thread)
From: (Anonymous)
2003-05-04 08:44 am (UTC)
I had the same problems, all you do is get the versions needed from rpmfind, but download the rawhide i386 ones because they are slightly newer, be careful what you do install though, try to get the bare minimum needed because rawhide is a "tad" unstable.

LogJam now works fine on mine.
(Reply) (Parent) (Thread)