?

Log in

No account? Create an account
CVS Commit: +- More GtkSpell fixes. +- Split code into separate… - LogJam [entries|archive|friends|userinfo]
LogJam

[ website | LogJam ]
[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

[Feb. 20th, 2001|01:15 pm]
LogJam
logjam
[evan]
CVS Commit:
+- More GtkSpell fixes.
+- Split code into separate libraries.
+- Updated RPM .spec. (Tom)
LinkReply

Comments:
[User Picture]From: tydel
2001-02-20 01:40 pm (UTC)
The latest CVS version won't compile for me ... I tried running ./autogen.sh two times like I had to do with the last CVS build, but that doesn't seem to work either. Information of the error follows:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/xmms -I/usr/lib/glib/include -D_REENTRANT -I/usr/X11R6/include
-Wall -g -c dotconf.c
dotconf.c:17: spawn.h: No such file or directory
make[2]: *** [dotconf.o] Error 1
make[2]: Leaving directory `/home/tydel/loserjabber/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tydel/loserjabber'
make: *** [all-recursive-am] Error 2
(Reply) (Thread)
[User Picture]From: spot
2001-02-20 02:56 pm (UTC)

cannot reproduce error

and just to be nice, i built CVS rpms for j00.

ftp://people.redhat.com/tcallawa
(Reply) (Parent) (Thread)
[User Picture]From: damion
2001-02-20 09:58 pm (UTC)

I had the same problem.

I configured without gnome, and I got a bunch of those. In addition, I would get errors that said there was a syntax error before every "VERSION". So what I did was go to each of these, comment out the spawn.h, and replace the VERSIONs with 2.1.5. Compiled fine and works fine.
(Reply) (Parent) (Thread)
[User Picture]From: nachtfalke
2001-02-21 03:54 am (UTC)
spawn.h is in the libhalfgnome subdir.
As a kludge, I used
make CFLAGS="-I/home/nachtfalke/devel/loserjabber/libhalfgnome"
It compiled without a hitch, so just use CFLAGS=-I to tell make where to look for include files.
(Reply) (Parent) (Thread)