?

Log in

No account? Create an account
sqlite error in 4.5.2 - LogJam [entries|archive|friends|userinfo]
LogJam

[ website | LogJam ]
[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

sqlite error in 4.5.2 [Jan. 4th, 2006|12:08 am]
LogJam

logjam

[pantsgolem]
When attempting to read/write to the offline DB, I'm getting nothing but "library routine called out of sequence" errors (code 21). My sqlite version is 3.2.2 on suse 10. Logjam 4.5.1 works fine.
LinkReply

Comments:
[User Picture]From: hofi
2006-01-04 07:22 pm (UTC)
i'm seeing that one as well

debian testing, garnome gnome build

ii libsqlite3-0 3.2.7-1 SQLite 3 shared library
ii libsqlite3-dev 3.2.7-1 SQLite 3 development files
ii sqlite3 3.2.7-1 A command line interface for SQLite
(Reply) (Thread)
From: evan
2006-01-09 06:40 am (UTC)
I'm getting it now too. It appears to be because sqlite checks which thread its being called from and puts out the error if it's not all from the same thread, regardless of whether your code is actually safe.

Looks like a complicated fix. :(

I believe it hasn't come up before because the earlier Debians were compiled without the sqlite flag that does this check. ... ?
(Reply) (Parent) (Thread)
From: the_mart
2006-01-09 09:13 pm (UTC)

I’m getting the error too on Fedora Core 4 with sqlite-3.1.2-3. I compiled from source and also tried the version from the “Fedora Extras” Yum repository. Version 4.5.1 works fine though.

(Reply) (Parent) (Thread)
From: evan
2006-01-09 10:24 pm (UTC)
If you have a sec, could you find the flags that the fedora package was built with?
(Reply) (Parent) (Thread)
From: evan
2006-01-10 10:47 pm (UTC)
This is completely my fault, and a stupid bug. I'll post a 4.5.3 when I get the chance.
(Reply) (Parent) (Thread)
From: the_mart
2006-01-11 05:22 pm (UTC)

Ok, that’s handy, because I’m not totally sure how I’d go about finding out how the Fedora rpm was packaged.

Thanks for a fantastic piece of software!

(Reply) (Parent) (Thread)
[User Picture]From: henman
2006-02-17 04:46 am (UTC)
Have you found an RPM of 4.5.3 for Fedora? The Fedora Extras site only has 4.5.1 and 4.5.2 (for FC4 - didn't check other versions of Fedora).
(Reply) (Parent) (Thread)
From: evan
2006-01-10 10:47 pm (UTC)
This is completely my fault, and a stupid bug. I'll post a 4.5.3 when I get the chance.
(Reply) (Parent) (Thread)
[User Picture]From: hofi
2006-01-11 05:03 pm (UTC)
well, no worries, we're all glad you've written such great software.
(Reply) (Parent) (Thread)